CVE-2022-23542
High
Description
OpenFGA is an authorization/permission engine built for developers and inspired by Google Zanzibar. During an internal security assessment, it was discovered that OpenFGA version 0.3.0 is vulnerable to authorization bypass under certain conditions. This issue has been patched in version 0.3.1 and is backward compatible.
SeverityHigh
CVSS7.7
Exploit probability—
ProductOpenfga
PublishedDec 20, 2022
First seenDec 20, 2022
Weakness typeCWE-285CWE-285
How to fix
Update
- openfga openfga0.3.1 or later
- github.com/openfga/openfga0.3.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| openfga openfga | v < 0.3.1 | 0.3.1 |
| github.com/openfga/openfgaGo | 0.3.0 ≤ v < 0.3.1 | 0.3.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.