CVE-2022-23548
Medium
Description
Discourse is an option source discussion platform. Prior to version 2.8.14 on the `stable` branch and version 2.9.0.beta16 on the `beta` and `tests-passed` branches, parsing posts can be susceptible to regular expression denial of service (ReDoS) attacks. This issue is patched in versions 2.8.14 and 2.9.0.beta16. There are no known workarounds.
SeverityMedium
CVSS6.5
Exploit probability—
Product
Discourse
PublishedJan 5, 2023
First seenJan 5, 2023
Weakness typeCWE-1333CWE-1333
How to fix
Update
- discourse discourse2.8.14 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| discourse discourse | v < 2.8.14, 2.9.0, 3.0.0 | 2.8.14 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.