CVE-2022-23556
High
Description
CodeIgniter is a PHP full-stack web framework. This vulnerability may allow attackers to spoof their IP address when the server is behind a reverse proxy. This issue has been patched, please upgrade to version 4.2.11 or later, and configure `Config\App::$proxyIPs`. As a workaround, do not use `$request->getIPAddress()`.
SeverityHigh
CVSS7.0
Exploit probability—
Product
Codeigniter
PublishedDec 22, 2022
First seenDec 22, 2022
Weakness typeCWE-345CWE-345
How to fix
Update
- codeigniter codeigniter4.2.11 or later
- codeigniter4/framework4.2.11 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| codeigniter codeigniter | 4.0.0 ≤ v < 4.2.11 | 4.2.11 |
| codeigniter4/frameworkPackagist | v < 4.2.11 | 4.2.11 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.