CVE-2022-23623

High

Description

Frourio is a full stack framework, for TypeScript. Frourio users who uses frourio version prior to v0.26.0 and integration with class-validator through `validators/` folder are subject to a input validation vulnerability. Validators do not work properly for request bodies and queries in specific situations and some input is not validated at all. Users are advised to update frourio to v0.26.0 or later and to install `class-transformer` and `reflect-metadata`.

SeverityHigh
CVSS8.1
Exploit probability—
ProductFrourio
PublishedFeb 7, 2022
First seenFeb 7, 2022

How to fix

Update
  • frourio frourio0.26.0 or later
  • frourio0.26.0 or later

Affected products

ProductAffected versionsFixed in
frourio frouriov < 0.26.00.26.0
frourionpmv < 0.26.00.26.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.