CVE-2022-23624

High

Description

Frourio-express is a minimal full stack framework, for TypeScript. Frourio-express users who uses frourio-express version prior to v0.26.0 and integration with class-validator through `validators/` folder are subject to a input validation vulnerability. Validators do not work properly for request bodies and queries in specific situations and some input is not validated at all. Users are advised to update frourio to v0.26.0 or later and to install `class-transformer` and `reflect-metadata`.

SeverityHigh
CVSS8.1
Exploit probability—
ProductFrourio-express
PublishedFeb 7, 2022
First seenFeb 7, 2022

How to fix

Update
  • frourio frourio-express0.26.0 or later
  • frourio-express0.26.0 or later

Affected products

ProductAffected versionsFixed in
frourio frourio-expressv < 0.26.00.26.0
frourio-expressnpmv < 0.26.00.26.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.