CVE-2022-23647

High

Description

Prism is a syntax highlighting library. Starting with version 1.14.0 and prior to version 1.27.0, Prism's command line plugin can be used by attackers to achieve a cross-site scripting attack. The command line plugin did not properly escape its output, leading to the input text being inserted into the DOM as HTML code. Server-side usage of Prism is not impacted. Websites that do not use the Command Line plugin are also not impacted. This bug has been fixed in v1.27.0. As a workaround, do not use the command line plugin on untrusted inputs, or sanitize all code blocks (remove all HTML code text) from all code blocks that use the command line plugin.

SeverityHigh
CVSS7.5
Exploit probability—
ProductPrism
PublishedFeb 18, 2022
First seenFeb 18, 2022

How to fix

Update
  • prismjs prism1.27.0 or later
  • prismjs1.27.0 or later

Affected products

ProductAffected versionsFixed in
prismjs prism1.14.0 ≤ v < 1.27.01.27.0
prismjsnpm1.14.0 ≤ v < 1.27.01.27.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.