CVE-2022-23732
Description
A path traversal vulnerability was identified in GitHub Enterprise Server management console that allowed the bypass of CSRF protections. This could potentially lead to privilege escalation. To exploit this vulnerability, an attacker would need to target a user that was actively logged into the management console. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.5 and was fixed in versions 3.1.19, 3.2.11, 3.3.6, 3.4.1. This vulnerability was reported via the GitHub Bug Bounty program.
How to fix
- github enterprise_server3.1.19, 3.2.11, 3.3.6, 3.4.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github enterprise_server | v < 3.1.19, 3.2.0 ≤ v < 3.2.11, 3.3.0 ≤ v < 3.3.6, 3.4.0 ≤ v < 3.4.1 | 3.1.19, 3.2.11, 3.3.6, 3.4.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.