CVE-2022-23737

Medium

Description

An improper privilege management vulnerability was identified in GitHub Enterprise Server that allowed users with improper privileges to create or delete pages via the API. To exploit this vulnerability, an attacker would need to be added to an organization's repo with write permissions. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.7 and was fixed in versions 3.2.20, 3.3.15, 3.4.10, 3.5.7, and 3.6.3. This vulnerability was reported via the GitHub Bug Bounty program.

SeverityMedium
CVSS6.5
Exploit probability—
ProductGithub Enterprise Server
PublishedDec 1, 2022
First seenDec 1, 2022

How to fix

Update
  • github enterprise_server3.2.20, 3.3.15, 3.4.10, 3.5.7, 3.6.3 or later

Affected products

ProductAffected versionsFixed in
github enterprise_serverv < 3.2.20, 3.3.0 ≤ v < 3.3.15, 3.4.0 ≤ v < 3.4.10, 3.5.0 ≤ v < 3.5.7, 3.6.0 ≤ v < 3.6.33.2.20, 3.3.15, 3.4.10, 3.5.7, 3.6.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2022-23737 · Github Enterprise Server · Dark Radar