CVE-2022-24687
Medium
Description
HashiCorp Consul and Consul Enterprise 1.9.0 through 1.9.14, 1.10.7, and 1.11.2 clusters with at least one Ingress Gateway allow a user with service:write to register a specifically-defined service that can cause Consul servers to panic. Fixed in 1.9.15, 1.10.8, and 1.11.3.
SeverityMedium
CVSS6.5
Exploit probability—
ProductHashicorp Consul
PublishedFeb 24, 2022
First seenFeb 24, 2022
How to fix
Update
- hashicorp consul1.9.15, 1.10.8, 1.11.3 or later
- github.com/hashicorp/consul1.9.15, 1.10.8, 1.11.3 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| hashicorp consul | 1.8.0 ≤ v < 1.9.15, 1.10.0 ≤ v < 1.10.8, 1.11.0 ≤ v < 1.11.3 | 1.9.15, 1.10.8, 1.11.3 |
| github.com/hashicorp/consulGo | 1.8.0 ≤ v < 1.9.15, 1.10.0 ≤ v < 1.10.8, 1.11.0 ≤ v < 1.11.3 | 1.9.15, 1.10.8, 1.11.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.