CVE-2022-24710

Medium

Description

Weblate is a copyleft software web-based continuous localization system. Versions prior to 4.11 do not properly neutralize user input used in user name and language fields. Due to this improper neutralization it is possible to perform cross-site scripting via these fields. The issues were fixed in the 4.11 release. Users unable to upgrade are advised to add their own neutralize logic.

SeverityMedium
CVSS5.4
Exploit probability—
ProductWeblate
PublishedFeb 25, 2022
First seenFeb 25, 2022

How to fix

Update
  • weblate weblate4.11 or later
  • weblate4.11 or later

Affected products

ProductAffected versionsFixed in
weblate weblatev < 4.114.11
weblatePyPIv < 4.114.11

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.