CVE-2022-24720

Critical

Description

image_processing is an image processing wrapper for libvips and ImageMagick/GraphicsMagick. Prior to version 1.12.2, using the `#apply` method from image_processing to apply a series of operations that are coming from unsanitized user input allows the attacker to execute shell commands. This method is called internally by Active Storage variants, so Active Storage is vulnerable as well. The vulnerability has been fixed in version 1.12.2 of image_processing. As a workaround, users who process based on user input should always sanitize the user input by allowing only a constrained set of operations.

SeverityCritical
CVSS9.8
Exploit probability—
ProductImage Processing
PublishedMar 1, 2022
First seenMar 1, 2022

How to fix

Update
  • image_processing_project image_processing1.12.2 or later

Affected products

ProductAffected versionsFixed in
image_processing_project image_processingv < 1.12.21.12.2
debian debian_linux11.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.