CVE-2022-24728
Description
CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4 prior to version 4.18.0. The vulnerability allows someone to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. This problem has been patched in version 4.18.0. There are currently no known workarounds.
How to fix
- ckeditor ckeditor4.18.0 or later
- drupal drupal9.2.15, 9.3.8 or later
- oracle application_express22.1.1 or later
- ckeditor44.18.0 or later
- drupal/core9.2.15, 9.3.8 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| ckeditor ckeditor | 4.0 ≤ v < 4.18.0 | 4.18.0 |
| drupal drupal | 8.0.0 ≤ v < 9.2.15, 9.3.0 ≤ v < 9.3.8 | 9.2.15, 9.3.8 |
| oracle application_express | v < 22.1.1 | 22.1.1 |
| oracle commerce_merchandising | 11.3.2 | — |
| oracle financial_services_analytical_applications_infrastructure | 8.0.7.0.0 ≤ v ≤ 8.1.0.0.0, 8.1.1.0, 8.1.2.0, 8.1.2.1 | — |
| oracle financial_services_behavior_detection_platform | 8.1.1.0 ≤ v ≤ 8.1.2.1, 8.0.7.0, 8.0.8.0 | — |
| oracle financial_services_trade-based_anti_money_laundering | 8.0.7, 8.0.8 | — |
| oracle peoplesoft_enterprise_peopletools | 8.58, 8.59 | — |
| fedoraproject fedora | 36, 37 | — |
| ckeditor4npm | v < 4.18.0 | 4.18.0 |
| drupal/corePackagist | 8.0.0 ≤ v < 9.2.15, 9.3.0 ≤ v < 9.3.8 | 9.2.15, 9.3.8 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.