CVE-2022-24741

Low

Description

Nextcloud server is an open source, self hosted cloud style services platform. In affected versions an attacker can cause a denial of service by uploading specially crafted files which will cause the server to allocate too much memory / CPU. It is recommended that the Nextcloud Server is upgraded to 21.0.8 , 22.2.4 or 23.0.1. Users unable to upgrade should disable preview generation with the `'enable_previews'` config flag.

SeverityLow
CVSS3.5
Exploit probability—
ProductNextcloud Server
PublishedMar 9, 2022
First seenMar 9, 2022

How to fix

Update
  • nextcloud nextcloud_server21.0.8, 22.2.4 or later

Affected products

ProductAffected versionsFixed in
nextcloud nextcloud_server21.0.0 ≤ v < 21.0.8, 22.0.0 ≤ v < 22.2.4, 23.0.021.0.8, 22.2.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.