CVE-2022-24748

Medium

Description

Shopware is an open commerce platform based on the Symfony php Framework and the Vue javascript framework. In versions prior to 6.4.8.2 it is possible to modify customers and to create orders without App Permission. This issue is a result of improper api route checking. Users are advised to upgrade to version 6.4.8.2. There are no known workarounds.

SeverityMedium
CVSS6.8
Exploit probability—
ProductShopware
PublishedMar 9, 2022
First seenMar 9, 2022

How to fix

Update
  • shopware shopware6.4.8.2 or later
  • shopware/core6.4.8.2 or later

Affected products

ProductAffected versionsFixed in
shopware shopwarev < 6.4.8.26.4.8.2
shopware/corePackagistv < 6.4.8.26.4.8.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.