CVE-2022-24759
Description
`@chainsafe/libp2p-noise` contains TypeScript implementation of noise protocol, an encryption protocol used in libp2p. `@chainsafe/libp2p-noise` before 4.1.2 and 5.0.3 does not correctly validate signatures during the handshake process. This may allow a man-in-the-middle to pose as other peers and get those peers banned. Users should upgrade to version 4.1.2 or 5.0.3 to receive a patch. There are currently no known workarounds.
How to fix
- @chainsafe/libp2p-noise4.1.2, 5.0.3 or later
- chainsafe js-libp2p-noise4.1.2, 5.0.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| @chainsafe/libp2p-noisenpm | v < 4.1.2, 5.0.0 ≤ v < 5.0.3 | 4.1.2, 5.0.3 |
| chainsafe js-libp2p-noise | v < 4.1.2, 5.0.0 ≤ v < 5.0.3 | 4.1.2, 5.0.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.