CVE-2022-24775
High
Description
guzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8.4 and 2.1.1 are vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values. The issue is patched in 1.8.4 and 2.1.1. There are currently no known workarounds.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Guzzlephp Psr-7
PublishedMar 21, 2022
First seenMar 21, 2022
Weakness typeCWE-20Improper input validation
How to fix
Update
- guzzlephp psr-71.8.4, 2.1.1 or later
- drupal drupal9.2.16, 9.3.9 or later
- drupal/core9.2.16, 9.3.9 or later
- guzzlehttp/psr71.8.4, 2.1.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| guzzlephp psr-7 | v < 1.8.4, 2.0.0 ≤ v < 2.1.1 | 1.8.4, 2.1.1 |
| drupal drupal | 8.0.0 ≤ v < 9.2.16, 9.3.0 ≤ v < 9.3.9 | 9.2.16, 9.3.9 |
| drupal/corePackagist | 8.0.0 ≤ v < 9.2.16, 9.3.0 ≤ v < 9.3.9 | 9.2.16, 9.3.9 |
| guzzlehttp/psr7Packagist | v < 1.8.4, 2.0.0 ≤ v < 2.1.1 | 1.8.4, 2.1.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.