CVE-2022-24802

High

Description

deepmerge-ts is a typescript library providing functionality to deep merging of javascript objects. deepmerge-ts is vulnerable to Prototype Pollution via file deepmerge.ts, function defaultMergeRecords(). This issue has been patched in version 4.0.2. There are no known workarounds for this issue.

SeverityHigh
CVSS8.1
Exploit probability—
ProductDeepmerge-ts
PublishedApr 1, 2022
First seenApr 1, 2022
Weakness typeCWE-915CWE-915

How to fix

Update
  • deepmerge-ts_project deepmerge-ts4.0.2 or later
  • deepmerge-ts4.0.2 or later

Affected products

ProductAffected versionsFixed in
deepmerge-ts_project deepmerge-tsv < 4.0.24.0.2
deepmerge-tsnpmv < 4.0.24.0.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.