CVE-2022-24817

Critical

Description

Flux2 is an open and extensible continuous delivery solution for Kubernetes. Flux2 versions between 0.1.0 and 0.29.0, helm-controller 0.1.0 to v0.19.0, and kustomize-controller 0.1.0 to v0.23.0 are vulnerable to Code Injection via malicious Kubeconfig. In multi-tenancy deployments this can also lead to privilege escalation if the controller's service account has elevated permissions. Workarounds include disabling functionality via Validating Admission webhooks by restricting users from setting the `spec.kubeConfig` field in Flux `Kustomization` and `HelmRelease` objects. Additional mitigations include applying restrictive AppArmor and SELinux profiles on the controller’s pod to limit what binaries can be executed. This vulnerability is fixed in kustomize-controller v0.23.0 and helm-controller v0.19.0, both included in flux2 v0.29.0

SeverityCritical
CVSS9.9
Exploit probability—
ProductFluxcd Flux2
PublishedMay 6, 2022
First seenMay 6, 2022

How to fix

Update
  • fluxcd flux20.29.0 or later
  • fluxcd helm-controller0.19.0 or later
  • fluxcd kustomize-controller0.23.0 or later
  • github.com/fluxcd/flux20.29.0 or later
  • github.com/fluxcd/kustomize-controller0.23.0 or later
  • github.com/fluxcd/helm-controller0.19.0 or later

Affected products

ProductAffected versionsFixed in
fluxcd flux20.1.0 ≤ v < 0.29.00.29.0
fluxcd helm-controller0.2.0 ≤ v < 0.19.00.19.0
fluxcd kustomize-controller0.1.0 ≤ v < 0.23.00.23.0
github.com/fluxcd/flux2Go0.1.0 ≤ v < 0.29.00.29.0
github.com/fluxcd/kustomize-controllerGo0.1.0 ≤ v < 0.23.00.23.0
github.com/fluxcd/helm-controllerGo0.2.0 ≤ v < 0.19.00.19.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.