CVE-2022-24822

High

Description

Podium is a library for building micro frontends. @podium/layout is a module for building a Podium layout server, and @podium/proxy is a module for proxying HTTP requests from a layout server to a podlet server. In @podium/layout prior to version 4.6.110 and @podium/proxy prior to version 4.2.74, an attacker using the `Trailer` header as part of the request against proxy endpoints has the ability to take down the server. All Podium layouts that include podlets with proxy endpoints are affected. `@podium/layout`, which is the main way developers/users are vulnerable to this exploit, has been patched in version `4.6.110`. All earlier versions are vulnerable.`@podium/proxy`, which is the source of the vulnerability and is used by `@podium/layout` has been patched in version `4.2.74`. All earlier versions are vulnerable. It is not easily possible to work around this issue without upgrading.

SeverityHigh
CVSS7.5
Exploit probability—
ProductFinn Podium Layout
PublishedApr 6, 2022
First seenApr 6, 2022
Weakness typeCWE-248CWE-248

How to fix

Update
  • finn podium_layout4.6.110 or later
  • finn podium_proxy4.2.74 or later
  • @podium/layout4.6.110 or later
  • @podium/proxy4.2.74 or later

Affected products

ProductAffected versionsFixed in
finn podium_layoutv < 4.6.1104.6.110
finn podium_proxyv < 4.2.744.2.74
@podium/layoutnpmv < 4.6.1104.6.110
@podium/proxynpmv < 4.2.744.2.74

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.