CVE-2022-24858
Description
next-auth v3 users before version 3.29.2 are impacted. next-auth version 4 users before version 4.3.2 are also impacted. Upgrading to 3.29.2 or 4.3.2 will patch this vulnerability. If you are not able to upgrade for any reason, you can add a configuration to your callbacks option. If you already have a `redirect` callback, make sure that you match the incoming `url` origin against the `baseUrl`.
How to fix
- nextauth.js next-auth3.29.2, 4.3.2 or later
- next-auth3.29.2, 4.3.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nextauth.js next-auth | 3.0.0 ≤ v < 3.29.2, 4.0.0 ≤ v < 4.3.2 | 3.29.2, 4.3.2 |
| next-authnpm | v < 3.29.2, 4.0.0 ≤ v < 4.3.2 | 3.29.2, 4.3.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.