CVE-2022-24871
Description
Shopware is an open commerce platform based on Symfony Framework and Vue. In affected versions an attacker can abuse the Admin SDK functionality on the server to read or update internal resources. Users are advised to update to the current version 6.4.10.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. There are no known workarounds for this issue.
How to fix
- shopware shopware6.4.10.1 or later
- shopware/platform6.4.10.1 or later
- shopware/core6.4.10.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| shopware shopware | v < 6.4.10.1 | 6.4.10.1 |
| shopware/platformPackagist | v < 6.4.10.1 | 6.4.10.1 |
| shopware/corePackagist | v < 6.4.10.1 | 6.4.10.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.