CVE-2022-24873
Medium
Description
Shopware is an open source e-commerce software platform. Prior to version 5.7.9, Shopware is vulnerable to non-stored cross-site scripting in the storefront. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.
SeverityMedium
CVSS5.4
Exploit probability—
Product
Shopware
PublishedApr 28, 2022
First seenApr 28, 2022
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- shopware shopware5.7.9 or later
- shopware/shopware5.7.9 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| shopware shopware | 5.0.0 ≤ v < 5.7.9 | 5.7.9 |
| shopware/shopwarePackagist | v < 5.7.9 | 5.7.9 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.