CVE-2022-24891
Description
ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, there is a potential for a cross-site scripting vulnerability in ESAPI caused by a incorrect regular expression for "onsiteURL" in the **antisamy-esapi.xml** configuration file that can cause "javascript:" URLs to fail to be correctly sanitized. This issue is patched in ESAPI 2.3.0.0. As a workaround, manually edit the **antisamy-esapi.xml** configuration files to change the "onsiteURL" regular expression. More information about remediation of the vulnerability, including the workaround, is available in the maintainers' release notes and security bulletin.
How to fix
- owasp enterprise_security_api2.3.0.0 or later
- org.owasp.esapi:esapi2.3.0.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| owasp enterprise_security_api | v < 2.3.0.0 | 2.3.0.0 |
| oracle weblogic_server | 12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0 | — |
| netapp active_iq_unified_manager | No range specified | — |
| netapp oncommand_workflow_automation | No range specified | — |
| org.owasp.esapi:esapiMaven | v < 2.3.0.0 | 2.3.0.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.