CVE-2022-24897

High

Description

APIs to evaluate content with Velocity is a package for APIs to evaluate content with Velocity. Starting with version 2.3 and prior to 12.6.7, 12.10.3, and 13.0, the velocity scripts are not properly sandboxed against using the Java File API to perform read or write operations on the filesystem. Writing an attacking script in Velocity requires the Script rights in XWiki so not all users can use it, and it also requires finding an XWiki API which returns a File. The problem has been patched in versions 12.6.7, 12.10.3, and 13.0. There is no easy workaround for fixing this vulnerability other than upgrading and being careful when giving Script rights.

SeverityHigh
CVSS7.5
Exploit probability—
ProductXwiki
PublishedMay 2, 2022
First seenMay 2, 2022

How to fix

Update
  • xwiki xwiki12.6.7, 12.10.3 or later
  • org.xwiki.commons:xwiki-commons-velocity12.6.7, 12.10.3 or later

Affected products

ProductAffected versionsFixed in
xwiki xwiki2.3 ≤ v < 12.6.7, 12.7 ≤ v < 12.10.312.6.7, 12.10.3
org.xwiki.commons:xwiki-commons-velocityMaven2.3.0 ≤ v < 12.6.7, 12.7.0 ≤ v < 12.10.312.6.7, 12.10.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.