CVE-2022-24898
Description
org.xwiki.commons:xwiki-commons-xml is a common module used by other XWiki top level projects. Starting in version 2.7 and prior to versions 12.10.10, 13.4.4, and 13.8-rc-1, it is possible for a script to access any file accessing to the user running XWiki application server with XML External Entity Injection through the XML script service. The problem has been patched in versions 12.10.10, 13.4.4, and 13.8-rc-1. There is no easy workaround for fixing this vulnerability other than upgrading and being careful when giving Script rights.
How to fix
- xwiki commons12.10.10, 13.4.4, 13.8 or later
- org.xwiki.commons:xwiki-commons-xml12.10.10, 13.4.4, 13.8-rc-1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| xwiki commons | 2.7 ≤ v < 12.10.10, 13.0 ≤ v < 13.4.4, 13.5 ≤ v < 13.8 | 12.10.10, 13.4.4, 13.8 |
| org.xwiki.commons:xwiki-commons-xmlMaven | 2.7 ≤ v < 12.10.10, 13.0.0 ≤ v < 13.4.4, 13.5-rc-1 ≤ v < 13.8-rc-1 | 12.10.10, 13.4.4, 13.8-rc-1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.