CVE-2022-25327

Medium

Description

The PAM module for fscrypt doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to version 0.3.3 or above

SeverityMedium
CVSS5.5
Exploit probability—
ProductGoogle Fscrypt
PublishedFeb 25, 2022
First seenFeb 25, 2022
Weakness typeCWE-255CWE-255

How to fix

Update
  • google fscrypt0.3.3 or later
  • github.com/google/fscrypt0.3.3 or later

Affected products

ProductAffected versionsFixed in
google fscryptv < 0.3.30.3.3
github.com/google/fscryptGov < 0.3.30.3.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.