CVE-2022-25598

High

Description

Apache DolphinScheduler user registration is vulnerable to Regular express Denial of Service (ReDoS) attacks, Apache DolphinScheduler users should upgrade to version 2.0.5 or higher.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Dolphinscheduler
PublishedMar 30, 2022
First seenMar 30, 2022
Weakness typeCWE-1333CWE-1333

How to fix

Update
  • apache dolphinscheduler2.0.5 or later
  • org.apache.dolphinscheduler:dolphinscheduler2.0.5 or later
  • apache-dolphinscheduler2.0.5 or later

Affected products

ProductAffected versionsFixed in
apache dolphinschedulerv < 2.0.52.0.5
org.apache.dolphinscheduler:dolphinschedulerMavenv < 2.0.52.0.5
apache-dolphinschedulerPyPIv < 2.0.52.0.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.