CVE-2022-28730

Medium

Description

A carefully crafted request on AJAXPreview.jsp could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This vulnerability leverages CVE-2021-40369, where the Denounce plugin dangerously renders user-supplied URLs. Upon re-testing CVE-2021-40369, it appears that the patch was incomplete as it was still possible to insert malicious input via the Denounce plugin. Apache JSPWiki users should upgrade to 2.11.3 or later.

SeverityMedium
CVSS6.1
Exploit probability—
ProductApache Jspwiki
PublishedAug 4, 2022
First seenAug 4, 2022

How to fix

Update
  • apache jspwiki2.11.3 or later
  • org.apache.jspwiki:jspwiki-main2.11.3 or later

Affected products

ProductAffected versionsFixed in
apache jspwikiv < 2.11.32.11.3
org.apache.jspwiki:jspwiki-mainMavenv < 2.11.32.11.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.