CVE-2022-29158
High
Description
Apache OFBiz up to version 18.12.05 is vulnerable to Regular Expression Denial of Service (ReDoS) in the way it handles URLs provided by external, unauthenticated users. Upgrade to 18.12.06 or apply patches at https://issues.apache.org/jira/browse/OFBIZ-12599
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Ofbiz
PublishedSep 2, 2022
First seenSep 2, 2022
Weakness typeCWE-1333CWE-1333
How to fix
Update
- apache ofbiz18.12.06 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache ofbiz | v < 18.12.06 | 18.12.06 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.