CVE-2022-29178

High

Description

Cilium is open source software for providing and securing network connectivity and loadbalancing between application workloads. Cilium prior to versions 1.9.16, 1.10.11, and 1.11.15 contains an incorrect default permissions vulnerability. Operating Systems with users belonging to the group ID 1000 can access the API of Cilium via Unix domain socket available on the host where Cilium is running. This could allow malicious users to compromise integrity as well as system availability on that host. The problem has been fixed and the patch is available in versions 1.9.16, 1.10.11, and 1.11.5. A potential workaround is to modify Cilium's DaemonSet to run with a certain command, which can be found in the GitHub Security Advisory for this vulnerability.

SeverityHigh
CVSS8.8
Exploit probability—
ProductCilium
PublishedMay 20, 2022
First seenMay 20, 2022
Weakness typeCWE-276CWE-276

How to fix

Update
  • cilium cilium1.9.16, 1.10.11, 1.11.5 or later
  • github.com/cilium/cilium1.11.5, 1.10.11, 1.9.16 or later

Affected products

ProductAffected versionsFixed in
cilium ciliumv < 1.9.16, 1.10.0 ≤ v < 1.10.11, 1.11.0 ≤ v < 1.11.51.9.16, 1.10.11, 1.11.5
github.com/cilium/ciliumGo1.11.0 ≤ v < 1.11.5, 1.10.0 ≤ v < 1.10.11, v < 1.9.161.11.5, 1.10.11, 1.9.16

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.