CVE-2022-30324
Critical
Description
HashiCorp Nomad and Nomad Enterprise version 0.2.0 up to 1.3.0 were impacted by go-getter vulnerabilities enabling privilege escalation through the artifact stanza in submitted jobs onto the client agent host. Fixed in 1.1.14, 1.2.8, and 1.3.1.
SeverityCritical
CVSS9.8
Exploit probability—
ProductHashicorp Nomad
PublishedJun 2, 2022
First seenJun 2, 2022
How to fix
Update
- hashicorp nomad1.1.14, 1.2.8 or later
- github.com/hashicorp/nomad1.1.14, 1.2.8, 1.3.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| hashicorp nomad | 0.2.0 ≤ v < 1.1.14, 1.2.0 ≤ v < 1.2.8, 1.3.0 | 1.1.14, 1.2.8 |
| github.com/hashicorp/nomadGo | 0.2.0 ≤ v < 1.1.14, 1.2.0 ≤ v < 1.2.8, 1.3.0 ≤ v < 1.3.1 | 1.1.14, 1.2.8, 1.3.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.