CVE-2022-31014
Description
Nextcloud server is an open source personal cloud server. Affected versions were found to be vulnerable to SMTP command injection. The impact varies based on which commands are supported by the backend SMTP server. However, the main risk here is that the attacker can then hijack an already-authenticated SMTP session and run arbitrary SMTP commands as the email user, such as sending emails to other users, changing the FROM user, and so on. As before, this depends on the configuration of the server itself, but newlines should be sanitized to mitigate such arbitrary SMTP command injection. It is recommended that the Nextcloud Server is upgraded to 22.2.8 , 23.0.5 or 24.0.1. There are no known workarounds for this issue.
How to fix
- nextcloud nextcloud_server19.0.13.7, 22.2.8, 20.0.14.6, 21.0.9.5, 23.0.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nextcloud nextcloud_server | v < 19.0.13.7, v < 22.2.8, 20.0.0 ≤ v < 20.0.14.6, 21.0.0 ≤ v < 21.0.9.5, 23.0.0 ≤ v < 23.0.5, 24.0.0 | 19.0.13.7, 22.2.8, 20.0.14.6, 21.0.9.5, 23.0.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.