CVE-2022-31030

Medium

Description

containerd is an open source container runtime. A bug was found in the containerd's CRI implementation where programs inside a container can cause the containerd daemon to consume memory without bound during invocation of the `ExecSync` API. This can cause containerd to consume all available memory on the computer, denying service to other legitimate workloads. Kubernetes and crictl can both be configured to use containerd's CRI implementation; `ExecSync` may be used when running probes or when executing processes via an "exec" facility. This bug has been fixed in containerd 1.6.6 and 1.5.13. Users should update to these versions to resolve the issue. Users unable to upgrade should ensure that only trusted images and commands are used.

SeverityMedium
CVSS5.5
Exploit probability—
ProductLinuxfoundation Containerd
PublishedJun 9, 2022
First seenJun 9, 2022

How to fix

Affected products

ProductAffected versionsFixed in
linuxfoundation containerdv < 1.5.13, 1.6.0 ≤ v < 1.6.61.5.13, 1.6.6
debian debian_linux11.0—
fedoraproject fedora35, 36—
github.com/containerd/containerdGov < 1.5.13, 1.6.0 ≤ v < 1.6.61.5.13, 1.6.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.