CVE-2022-31042

High

Description

Guzzle is an open source PHP HTTP client. In affected versions the `Cookie` headers on requests are sensitive information. On making a request using the `https` scheme to a server which responds with a redirect to a URI with the `http` scheme, or on making a request to a server which responds with a redirect to a a URI to a different host, we should not forward the `Cookie` header on. Prior to this fix, only cookies that were managed by our cookie middleware would be safely removed, and any `Cookie` header manually added to the initial request would not be stripped. We now always strip it, and allow the cookie middleware to re-add any cookies that it deems should be there. Affected Guzzle 7 users should upgrade to Guzzle 7.4.4 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.7 or 7.4.4. Users unable to upgrade may consider an alternative approach to use your own redirect middleware, rather than ours. If you do not require or expect redirects to be followed, one should simply disable redirects all together.

SeverityHigh
CVSS7.5
Exploit probability—
ProductGuzzle
PublishedJun 10, 2022
First seenJun 10, 2022

How to fix

Update
  • guzzlephp guzzle6.5.7, 7.4.4 or later
  • drupal drupal9.2.21, 9.3.16 or later
  • drupal/core9.2.21, 9.3.16 or later
  • guzzlehttp/guzzle6.5.7, 7.4.4 or later

Affected products

ProductAffected versionsFixed in
guzzlephp guzzlev < 6.5.7, 7.0.0 ≤ v < 7.4.46.5.7, 7.4.4
drupal drupal9.2.0 ≤ v < 9.2.21, 9.3.0 ≤ v < 9.3.16, 9.4.09.2.21, 9.3.16
debian debian_linux11.0—
drupal/corePackagist8.0.0 ≤ v < 9.2.21, 9.3.0 ≤ v < 9.3.169.2.21, 9.3.16
guzzlehttp/guzzlePackagist4.0.0 ≤ v < 6.5.7, 7.0.0 ≤ v < 7.4.46.5.7, 7.4.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.