CVE-2022-31043

High

Description

Guzzle is an open source PHP HTTP client. In affected versions `Authorization` headers on requests are sensitive information. On making a request using the `https` scheme to a server which responds with a redirect to a URI with the `http` scheme, we should not forward the `Authorization` header on. This is much the same as to how we don't forward on the header if the host changes. Prior to this fix, `https` to `http` downgrades did not result in the `Authorization` header being removed, only changes to the host. Affected Guzzle 7 users should upgrade to Guzzle 7.4.4 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.7 or 7.4.4. Users unable to upgrade may consider an alternative approach which would be to use their own redirect middleware. Alternately users may simply disable redirects all together if redirects are not expected or required.

SeverityHigh
CVSS7.5
Exploit probability—
ProductGuzzle
PublishedJun 10, 2022
First seenJun 10, 2022

How to fix

Update
  • guzzlephp guzzle6.5.7, 7.4.4 or later
  • drupal drupal9.2.21, 9.3.16 or later

Affected products

ProductAffected versionsFixed in
guzzlephp guzzlev < 6.5.7, 7.0.0 ≤ v < 7.4.46.5.7, 7.4.4
drupal drupal9.2.0 ≤ v < 9.2.21, 9.3.0 ≤ v < 9.3.16, 9.4.09.2.21, 9.3.16
debian debian_linux11.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.