CVE-2022-31059

Medium

Description

Discourse Calendar is a calendar plugin for Discourse, an open-source messaging app. Prior to version 1.0.1, parsing and rendering of Event names can be susceptible to cross-site scripting (XSS) attacks. This vulnerability only affects sites which have modified or disabled Discourse’s default Content Security Policy. This issue is patched in version 1.0.1 of the Discourse Calendar plugin. As a workaround, ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.

SeverityMedium
CVSS6.5
Exploit probability—
ProductDiscourse Calendar
PublishedJun 14, 2022
First seenJun 14, 2022

How to fix

Update
  • discourse discourse_calendar1.0.1 or later

Affected products

ProductAffected versionsFixed in
discourse discourse_calendarv < 1.0.11.0.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.