CVE-2022-31106

High

Description

Underscore.deep is a collection of Underscore mixins that operate on nested objects. Versions of `underscore.deep` prior to version 0.5.3 are vulnerable to a prototype pollution vulnerability. An attacker can craft a malicious payload and pass it to `deepFromFlat`, which would pollute any future Objects created. Any users that have `deepFromFlat` or `deepPick` (due to its dependency on `deepFromFlat`) in their code should upgrade to version 0.5.3 as soon as possible. Users unable to upgrade may mitigate this issue by modifying `deepFromFlat` to prevent specific keywords which will prevent this from happening.

SeverityHigh
CVSS8.3
Exploit probability—
ProductClever Underscore.deep
PublishedJun 28, 2022
First seenJun 28, 2022

How to fix

Update
  • clever underscore.deep0.5.3 or later

Affected products

ProductAffected versionsFixed in
clever underscore.deepv < 0.5.30.5.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2022-31106 · Clever Underscore.deep · Dark Radar