CVE-2022-31118
Description
Nextcloud server is an open source personal cloud solution. In affected versions an attacker could brute force to find if federated sharing is being used and potentially try to brute force access tokens for federated shares (`a-zA-Z0-9` ^ 15). It is recommended that the Nextcloud Server is upgraded to 22.2.9, 23.0.6 or 24.0.2. Users unable to upgrade may disable federated sharing via the Admin Sharing settings in `index.php/settings/admin/sharing`.
How to fix
- nextcloud nextcloud_server22.2.9, 23.0.6, 24.0.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nextcloud nextcloud_server | v < 22.2.9, 23.0.0 ≤ v < 23.0.6, 24.0.0 ≤ v < 24.0.2 | 22.2.9, 23.0.6, 24.0.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.