CVE-2022-31133
Description
HumHub is an Open Source Enterprise Social Network. Affected versions of HumHub are vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. For exploitation, the attacker would need a permission to administer the Spaces feature. The names of individual "spaces" are not properly escaped and so an attacker with sufficient privilege could insert malicious javascript into a space name and exploit system users who visit that space. It is recommended that the HumHub is upgraded to 1.11.4, 1.10.5. There are no known workarounds for this issue.
How to fix
- humhub humhub1.10.5, 1.11.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| humhub humhub | v < 1.10.5, 1.11.0 ≤ v < 1.11.4 | 1.10.5, 1.11.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.