CVE-2022-31136

Medium

Description

Bookwyrm is an open source social reading and reviewing program. Versions of Bookwyrm prior to 0.4.1 did not properly sanitize html being rendered to users. Unprivileged users are able to inject scripts into user profiles, book descriptions, and statuses. These vulnerabilities may be exploited as cross site scripting attacks on users viewing these fields. Users are advised to upgrade to version 0.4.1. There are no known workarounds for this issue.

SeverityMedium
CVSS6.3
Exploit probability—
ProductBookwyrm
PublishedJul 7, 2022
First seenJul 7, 2022

How to fix

Update
  • joinbookwyrm bookwyrm0.4.1 or later

Affected products

ProductAffected versionsFixed in
joinbookwyrm bookwyrmv < 0.4.10.4.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.