CVE-2022-31147

High

Description

The jQuery Validation Plugin (jquery-validation) provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service (ReDoS) when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix for CVE-2021-43306. Users should upgrade to version 1.19.5 to receive a patch.

SeverityHigh
CVSS7.5
Exploit probability—
ProductJqueryvalidation Jquery Validation
PublishedJul 14, 2022
First seenJul 14, 2022
Weakness typeCWE-1333CWE-1333

How to fix

Update
  • jqueryvalidation jquery_validation1.19.5 or later
  • jquery-validation1.19.5 or later

Affected products

ProductAffected versionsFixed in
jqueryvalidation jquery_validationv < 1.19.51.19.5
jquery-validationnpmv < 1.19.51.19.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.