CVE-2022-31148
Medium
Description
Shopware is an open source e-commerce software. In versions from 5.7.0 a persistent cross site scripting (XSS) vulnerability exists in the customer module. Users are recommend to update to the current version 5.7.14. You can get the update to 5.7.14 regularly via the Auto-Updater or directly via the download overview. There are no known workarounds for this issue.
SeverityMedium
CVSS5.4
Exploit probability—
Product
Shopware
PublishedAug 1, 2022
First seenAug 1, 2022
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- shopware shopware5.7.14 or later
- shopware/shopware5.7.14 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| shopware shopware | 5.7.0 ≤ v < 5.7.14 | 5.7.14 |
| shopware/shopwarePackagist | 5.7.0 ≤ v < 5.7.14 | 5.7.14 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.