CVE-2022-31157
High
Description
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the function used to generate random nonces was not sufficiently cryptographically complex. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.
SeverityHigh
CVSS7.5
Exploit probability—
ProductPackback Lti 1.3 Tool Library
PublishedJul 15, 2022
First seenJul 15, 2022
Weakness typeCWE-327CWE-327
How to fix
Update
- packback lti_1.3_tool_library5.0.0 or later
- packbackbooks/lti-1-3-php-library5.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| packback lti_1.3_tool_library | v < 5.0.0 | 5.0.0 |
| packbackbooks/lti-1-3-php-libraryPackagist | v < 5.0 | 5.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.