CVE-2022-31175

Medium

Description

CKEditor 5 is a JavaScript rich text editor. A cross-site scripting vulnerability has been discovered affecting three optional CKEditor 5's packages in versions prior to 35.0.1. The vulnerability allowed to trigger a JavaScript code after fulfilling special conditions. The affected packages are `@ckeditor/ckeditor5-markdown-gfm`, `@ckeditor/ckeditor5-html-support`, and `@ckeditor/ckeditor5-html-embed`. The specific conditions are 1) Using one of the affected packages. In case of `ckeditor5-html-support` and `ckeditor5-html-embed`, additionally, it was required to use a configuration that allows unsafe markup inside the editor. 2) Destroying the editor instance and 3) Initializing the editor on an element and using an element other than `<textarea>` as a base. The root cause of the issue was a mechanism responsible for updating the source element with the markup coming from the CKEditor 5 data pipeline after destroying the editor. This vulnerability might affect a small percent of integrators that depend on dynamic editor initialization/destroy and use Markdown, General HTML Support or HTML embed features. The problem has been recognized and patched. The fix is available in version 35.0.1. There are no known workarounds for this issue.

SeverityMedium
CVSS5.8
Exploit probability—
ProductCkeditor5-html-embed
PublishedAug 3, 2022
First seenAug 3, 2022

How to fix

Update
  • ckeditor ckeditor5-html-embed35.0.1 or later
  • ckeditor ckeditor5-html-support35.0.1 or later
  • ckeditor ckeditor5-markdown-gfm35.0.1 or later
  • @ckeditor/ckeditor5-markdown-gfm35.0.1 or later
  • @ckeditor/ckeditor5-html-support35.0.1 or later
  • @ckeditor/ckeditor5-html-embed35.0.1 or later

Affected products

ProductAffected versionsFixed in
ckeditor ckeditor5-html-embedv < 35.0.135.0.1
ckeditor ckeditor5-html-supportv < 35.0.135.0.1
ckeditor ckeditor5-markdown-gfmv < 35.0.135.0.1
@ckeditor/ckeditor5-markdown-gfmnpmv < 35.0.135.0.1
@ckeditor/ckeditor5-html-supportnpmv < 35.0.135.0.1
@ckeditor/ckeditor5-html-embednpmv < 35.0.135.0.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.