CVE-2022-31181

Critical

Description

PrestaShop is an Open Source e-commerce platform. In versions from 1.6.0.10 and before 1.7.8.7 PrestaShop is subject to an SQL injection vulnerability which can be chained to call PHP's Eval function on attacker input. The problem is fixed in version 1.7.8.7. Users are advised to upgrade. Users unable to upgrade may delete the MySQL Smarty cache feature.

SeverityCritical
CVSS9.8
Exploit probability—
ProductPrestashop
PublishedAug 1, 2022
First seenAug 1, 2022

How to fix

Update
  • prestashop prestashop1.7.8.7 or later
  • prestashop/prestashop1.7.8.7 or later

Affected products

ProductAffected versionsFixed in
prestashop prestashop1.6.0.10 ≤ v < 1.7.8.71.7.8.7
prestashop/prestashopPackagist1.6.0.10 ≤ v < 1.7.8.71.7.8.7

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.