CVE-2022-31186
Description
NextAuth.js is a complete open source authentication solution for Next.js applications. An information disclosure vulnerability in `next-auth` before `v4.10.2` and `v3.29.9` allows an attacker with log access privilege to obtain excessive information such as an identity provider's secret in the log (which is thrown during OAuth error handling) and use it to leverage further attacks on the system, like impersonating the client to ask for extensive permissions. This issue has been patched in `v4.10.2` and `v3.29.9` by moving the log for `provider` information to the debug level. In addition, we added a warning for having the `debug: true` option turned on in production. If for some reason you cannot upgrade, you can user the `logger` configuration option by sanitizing the logs.
How to fix
- next-auth nextauth.js3.29.9, 4.10.2 or later
- next-auth3.29.9, 4.10.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| next-auth nextauth.js | v < 3.29.9, 4.0.0 ≤ v < 4.10.2 | 3.29.9, 4.10.2 |
| next-authnpm | v < 3.29.9, 4.0.0 ≤ v < 4.10.2 | 3.29.9, 4.10.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.