CVE-2022-31198

High

Description

OpenZeppelin Contracts is a library for secure smart contract development. This issue concerns instances of Governor that use the module `GovernorVotesQuorumFraction`, a mechanism that determines quorum requirements as a percentage of the voting token's total supply. In affected instances, when a proposal is passed to lower the quorum requirements, past proposals may become executable if they had been defeated only due to lack of quorum, and the number of votes it received meets the new quorum requirement. Analysis of instances on chain found only one proposal that met this condition, and we are actively monitoring for new occurrences of this particular issue. This issue has been patched in v4.7.2. Users are advised to upgrade. Users unable to upgrade should consider avoiding lowering quorum requirements if a past proposal was defeated for lack of quorum.

SeverityHigh
CVSS7.5
Exploit probability—
ProductOpenzeppelin Contracts
PublishedAug 1, 2022
First seenAug 1, 2022
Weakness typeCWE-682CWE-682

How to fix

Update
  • openzeppelin contracts4.7.2 or later
  • openzeppelin contracts_upgradeable4.7.2 or later
  • @openzeppelin/contracts4.7.2 or later
  • @openzeppelin/contracts-upgradeable4.7.2 or later

Affected products

ProductAffected versionsFixed in
openzeppelin contracts4.3.0 ≤ v < 4.7.24.7.2
openzeppelin contracts_upgradeable4.3.0 ≤ v < 4.7.24.7.2
@openzeppelin/contractsnpm4.3.0 ≤ v < 4.7.24.7.2
@openzeppelin/contracts-upgradeablenpm4.3.0 ≤ v < 4.7.24.7.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.