CVE-2022-32893
HighActively exploited (CISA KEV)
Description
An out-of-bounds write issue was addressed with improved bounds checking. This issue is fixed in iOS 15.6.1 and iPadOS 15.6.1, macOS Monterey 12.5.1, Safari 15.6.1. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited.
SeverityHigh
CVSS8.8
Exploit probability—
Product
Apple iOS and macOS
PublishedAug 24, 2022
First seenAug 24, 2022
Added to KEVAug 18, 2022
Weakness typeCWE-787Out-of-bounds write
How to fix
CISA required action
Apply updates per vendor instructions.
CISA due date: Sep 8, 2022Update
- apple safari15.6.1 or later
- apple ipados15.6.1 or later
- apple iphone_os15.6.1 or later
- apple macos12.5.1 or later
- webkitgtk webkitgtk2.36.7 or later
- wpewebkit wpe_webkit2.36.7 or later
Vendor advisories
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7SETAAXEPGNBMYKTUDFEZHS5LGSQ64QL/
- debian.org/security/2022/dsa-5220
- debian.org/security/2022/dsa-5219
- security.gentoo.org/glsa/202208-39
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YKJGV2EXVMYQW3OAJNI4WUTKKVMD2YYK/
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apple safari | v < 15.6.1 | 15.6.1 |
| apple ipados | v < 15.6.1 | 15.6.1 |
| apple iphone_os | v < 15.6.1 | 15.6.1 |
| apple macos | 12.0 ≤ v < 12.5.1 | 12.5.1 |
| fedoraproject fedora | 35, 36 | — |
| debian debian_linux | 10.0, 11.0 | — |
| webkitgtk webkitgtk | v < 2.36.7 | 2.36.7 |
| wpewebkit wpe_webkit | v < 2.36.7 | 2.36.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.