CVE-2022-34169

High

Description

The Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets. This can be used to corrupt Java class files generated by the internal XSLTC compiler and execute arbitrary Java bytecode. Users are recommended to update to version 2.7.3 or later. Note: Java runtimes (such as OpenJDK) include repackaged copies of Xalan.

SeverityHigh
CVSS7.5
Exploit probability—
ProductOracle Openjdk
PublishedJul 19, 2022
First seenJul 19, 2022
Weakness typeCWE-681CWE-681

How to fix

Affected products

ProductAffected versionsFixed in
oracle openjdk11 ≤ v ≤ 11.0.15, 13 ≤ v ≤ 13.0.11, 15 ≤ v ≤ 15.0.7, 17 ≤ v ≤ 17.0.3, 7, 8, 18—
apache xalan-javav ≤ 2.7.2—
debian debian_linux10.0, 11.0—
oracle graalvm20.3.6, 21.3.2, 22.1.0—
oracle jdk1.7.0, 1.8.0, 11.0.15.1, 17.0.3.1, 18.0.1.1—
oracle jre1.7.0, 1.8.0, 11.0.15.1, 17.0.3.1, 18.0.1.1—
fedoraproject fedora35, 36—
netapp 7-mode_transition_toolNo range specified—
netapp active_iq_unified_managerNo range specified—
netapp cloud_insights_acquisition_unitNo range specified—
netapp cloud_secure_agentNo range specified—
netapp hci_management_nodeNo range specified—
netapp oncommand_insightNo range specified—
netapp solidfireNo range specified—
netapp hci_compute_nodeNo range specified—
azul zulu6.47, 7.54, 8.62, 11.56, 13.48, 15.40, 17.34, 18.30—
xalan:xalanMavenv < 2.7.32.7.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.