CVE-2022-34384
Description
Dell SupportAssist Client Consumer (version 3.11.1 and prior), SupportAssist Client Commercial (version 3.2 and prior), Dell Command | Update, Dell Update, and Alienware Update versions before 4.5 contain a Local Privilege Escalation Vulnerability in the Advanced Driver Restore component. A local malicious user may potentially exploit this vulnerability, leading to privilege escalation.
How to fix
- dell alienware_update4.5.0 or later
- dell command_update4.5.0 or later
- dell update4.5.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| dell alienware_update | v < 4.5.0 | 4.5.0 |
| dell command_update | v < 4.5.0 | 4.5.0 |
| dell supportassist_for_business_pcs | v ≤ 3.2.0 | — |
| dell supportassist_for_home_pcs | v ≤ 3.11.2 | — |
| dell update | v < 4.5.0 | 4.5.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.